Registration Verification Code Issues
Incident Report for Sharkmob
Resolved
The issue has been addressed.
Posted Jun 10, 2022 - 11:44 CEST
Investigating
Some people who are trying to register, are currently not receiving their verification codes.
Posted Jun 10, 2022 - 11:06 CEST
This incident affected: Systems & Services (Login).